Update ELG stack

Description

As a user, I want to use an ELG stack more recent than the one provided by SIMP. Currently, SIMP works with Elasticsearch 2.3, Logstash 2.3, and Granafa 3.1.

  • Update simp/puppet-elasticsearch/simp-master to use latest, tagged version of elasticsearch/puppet-elasticsearch. The latest module uses Elasticsearch 5.X.

  • Update simp/puppet-logstash/simp-master to use latest, tagged version of elasticsearch/puppet-logstash. The latest module uses Logstash 5.X.

  • Update simp/pupmod-simp-simp_elasticsearch, accordingly

  • Update simp/pupmod-simp-simp_logstash, accordingly

  • Update simp/puppet-grafana, as needed to work with Elasticsearch/Logstash 5.x

  • Update simp/pupmod-simp-simp_grafana, accordingly

  • Update simp/grafana_dashboards, accordingly

Acceptance Criteria

None

Activity

Show:
Liz Nemsick
May 18, 2017, 12:39 PM

This work needs to be split into two tickets:
1 ticket to update to latest components and to verify these components interoperate
1 ticket to fix the filters and dashboards.

Labels

None

Epic Link

None

Story Points

8

Components

Assignee

Liz Nemsick

Sprint

None

Affects versions

Priority

Medium
Configure