simp_version returns 'unknown version' on systems not installed via rpm

Description

None

Acceptance Criteria

None

Activity

Show:
Nick Miller
June 26, 2017, 8:52 PM

simp::yum::repo::internet_simp_server and simp::yum::repo::internet_simp_dependencies do not work unless installed by rpm

Nick Miller
June 26, 2017, 8:54 PM

A possible solution to this would be to modify the distributed site.pp to set the file containing the simp.version file, instead of the simp::version class. That way we can version it with the SIMP version, not the pupmod-simp-simp module.

Trevor Vaughan
December 31, 2019, 7:06 PM

Functions as expected.

Labels

None

Epic Link

None

Story Points

None

Components

Affects versions

Priority

Medium
Configure