Add a FAQ entry regarding `puppet generate types` + too old version of Puppet error

Description

If you try to compile a system that is using a version of Puppet less than 4.10.4 and there are modules present that have been 'fixed' to have their composite namevars work with puppet generate types the following error will be output and the compile will fail:

The fix is to either downgrade the modules to a version prior to the fix and risk SERVER-94 environment contamination or to upgrade to Puppet 4.10.4+

Acceptance Criteria

None

Labels

None

Story Points

None

Components

Affects versions

Priority

Medium
Configure