Update to a Puppet 5 version of elastic/elasticsearch

Description

  • Verify pupmod-simp-simp_elasticsearch works with a version of elastic/elasticsearch that supports Puppet 5 (6.0.0 or later)

    • spec and acceptance tests

    • dogfooding

  • Update version range of elastic/elasticsearch in pupmod-simp-simp_elasticsearch's metadata.json

  • Fix version of elastic/elasticsearch specified in pupmod-simp-simp_elasticsearch's .fixtures.yml

Acceptance Criteria

None

Activity

Show:
Trevor Vaughan
December 31, 2019, 5:21 PM

ES and Puppet have moved so far forward at this point that it will probably be a new set of tickets if we decide to tackle this.

Labels

None

Epic Link

None

Story Points

None

Components

Priority

Medium
Configure