Most documentation in the broader SIMP ecosystem claims to support Puppet 6

Description

There appears to be a version restriction on SIMP to only support Puppet prior to version 6 (https://github.com/simp/simp-core/blob/master/metadata.json#L325). Virtually every available piece of documentation in SIMP does not reflect this, and in most cases would seem to indicate that SIMP does support Puppet 6. See below:

The changelog is particularly egregious as it makes actual references to Puppet 6 which at the very least are confusing. The other links (the scope of this problem is not limited to only those 3 links, but rather those provide examples) mention supporting Puppet v5.3 and later.

It's not reasonable to expect users to think Puppet v6 isn't supported in the release of 6.4 based on all of the available documentation.

Acceptance Criteria

None

Status

Labels

None

Story Points

None

Components

Sprint

Affects versions

6.4.0

Priority

Highest