Update pupmod-simp-simp_rsyslog EL8

Description

Update the module to support El8 as described in parent ticket 7433. Make sure all tests unit and acceptance run

Acceptance Criteria

None

Activity

Show:
Jeanne Greulich
January 7, 2020, 9:03 PM
  • update meta to support EL8 for centos, redhat and oraclelinux

  • add el8 test nodes

  • update .gitlab-ci.yaml to use 5.5.16 (in place of 5.5.10)

  • update Gemfile to use latest versions that contain EL8 data:
    gem 'simp-rspec-puppet-facts', ENV.fetch('SIMP_RSPEC_PUPPET_FACTS_VERSION', ['>= 2.4.0', '< 3.0.0'] )
    gem 'simp-rake-helpers', ENV.fetch('SIMP_RAKE_HELPERS_VERSION', ['>= 5.9', '< 6.0'])
    gem 'simp-beaker-helpers', ENV.fetch('SIMP_BEAKER_HELPERS_VERSION', ['>= 1.17.0', '< 2.0.0'])

  • update spec_helpers.rb as described in https://simp-project.atlassian.net/browse/SIMP-3430 and close corresponding ticket

  • update reference file: bundle exec puppet strings generate --format markdown --out REFERENCE.md'

Trevor Vaughan
February 14, 2020, 9:11 PM

added modifications for simp_rsyslog

Labels

None

Epic Link

Story Points

4

Components

Assignee

Trevor Vaughan

Sprint

None

Priority

Medium
Configure