EL8 compile fails when ssh::server::conf::manage_pam_sshd = true

Description

When Puppet compiles a catalog for EL8 and ssh::server::conf::manage_pam_sshd is true, the compiler will intentionally fail with an "Unsupported EL version" message, according to the logic at https://github.com/simp/pupmod-simp-ssh/blob/master/manifests/server/conf.pp#L428-L445.

Additionally, there is no templates/etc/pam.d/sshd_el8.epp template for EL8, as there is for EL6 and EL7.

Acceptance Criteria

None

Labels

None

Epic Link

None

Story Points

None

Components

Priority

Low
Configure