Update SIMP to support new PE LTS (PE 2019.8)

Description

Puppet has released its new Puppet Enterprise LTS, PE 2019.8.

  • SIMP supports all supported versions of PE, so it must be updated to support PE2019.8.

  • Note: Support for the old LTS, PE 2018.1 will overlap with the new LTS until 31 January 2021.

From https://puppet.com/docs/pe/2019.8/component_versions_in_recent_pe_releases.html:

PE Version

Puppet Agent

Puppet

Facter

Hiera

Resource API

MCollective

Ruby

OpenSSL

2019.8 (LTS)

6.16.0

6.16.0

3.14.11

3.6.0

1.8.13

N/A

2.5.8

1.1.1g

...

PE Version

Puppet Server

PuppetDB

r10k

Razor Server

Bolt Services

Agentless Catalog Executor (ACE) Services

PostgreSQL

Java

ActiveMQ

Nginx

2019.8 (LTS)

6.12.0

6.11.1

3.5.1

N/A

2.11.1

1.2.0

11.8

11.0

N/A

1.17.10

Acceptance Criteria

None

Story Points

None

Components

Affects versions

Priority

Medium

Epic Name

PE2019.8 LTS
Configure