simp.spec rhel >= 7 logic inappropriate

Description

The rhel logic in https://github.com/simp/simp-core/blob/master/src/assets/simp/build/simp.spec#L109-L112 needs to be removed. The SIMP server should install all puppet modules regardless of the OS version of the SIMP server, as it may be managing clients with other OS versions.

This ticket is to remove the if logic and move the pupeet module requires statements to the appropriate alphabetical location.

Acceptance Criteria

None

Labels

None

Epic Link

None

Story Points

None

Components

Assignee

Trevor Vaughan

Sprint

None

Priority

Medium
Configure