simp-cli FIPS mode tests cannot use simp-beaker-helpers with FIPS fix

Description

rubygem-simp-cli's FIPS-mode acceptance tests fail during FIPS-mode set up because of bugs in the version of simp-beaker-helpers resolved to by bundler. Specifically, bundler resolves to simp-beaker-helpers 1.14.3, which does not have the FIPS mode fix. Unfortunately, rubygem-simp-cli cannot use the version with the bug fix (>= 1.18.7), because that version requires HighLine gem >=2. rubygem-simp-cli uses its self-packaged version of HighLine, version 1.7.8.

This problem can be resolved when is completed. This ticket is to ensure the FIPS-mode acceptance tests pass and are not allowed to fail in the .gitlab-ci.yml when the self-packaged version of HighLine is updated.

Acceptance Criteria

None

Activity

Show:
Liz Nemsick
September 29, 2020, 12:29 PM

FIPS-mode tests were re-enabled with the move to HighLine 2.0.3

Labels

None

Epic Link

Story Points

1

Components

Assignee

Liz Nemsick

Sprint

None

Priority

Medium
Configure