nil data/common.yaml throws puppetserver warnings

Description

Each time a puppetserver compiling a catalog for an environment that contains the crypto_policy module, it will log a warning like the following:

Acceptance Criteria

None

Activity

Show:
Chris Tessmer
October 15, 2020, 10:24 PM

According to PUP-7414, this is due to the empty data/common.yaml file containing nil instead of a YAML hash:

vs

Done

Labels

Epic Link

None

Story Points

1

Components

Assignee

Chris Tessmer

Sprint

None

Affects versions

Priority

Medium
Configure