pupmod-simp-sssd picks the wrong sssd client package on Ubuntu

Description

sssd-client has not existed on any version of debian or ubuntu that I'm aware of. the sssd::install class should be using a case statement on the os family fact and picking the appropriate packages for the debian and ubuntu systems.

It should be picking some combination of
sssd - System Security Services Daemon – metapackage
sssd-ad - System Security Services Daemon – Active Directory back end
sssd-ad-common - System Security Services Daemon – PAC responder
sssd-common - System Security Services Daemon – common files
sssd-dbus - System Security Services Daemon – D-Bus responder
sssd-ipa - System Security Services Daemon – IPA back end
sssd-krb5 - System Security Services Daemon – Kerberos back end
sssd-krb5-common - System Security Services Daemon – Kerberos helpers
sssd-ldap - System Security Services Daemon – LDAP back end
sssd-proxy - System Security Services Daemon – proxy back end
sssd-tools - System Security Services Daemon – tools

depending on which services are selected.

Acceptance Criteria

None

Labels

None

Epic Link

None

Story Points

None

Priority

Medium
Configure